Image-Pro Plus

查找常见疑难解答
和指引资源

Image-Pro Plus

开始使用
开始使用

安装。设置。
开始使用。

最新重要版本

版本 7.0.1

所有拥有 v7.0 及更高版本的客户均可用

常见问题

Your Product Serial Number is printed directly on your Hardware Protection Key and can also be found on the ‘About’ dialog box. This can be launched by selecting “About <Product Name>” from the Help Menu from inside of the product.

在序列的第一个帧上创建 AOI。
转至“处理...操作”(Process...Operations)。
您的序列将被列为“第一个操作数”(First Operand)。
选择“添加”(Add) 作为操作。
“第二个操作数”(Second Operand) 应为“数字”(Number),并将数字设为“0”。
对于“将结果放入”(Put result in),选择“新图像”(New Image)。
单击“应用”(Apply) 后,将生成新的序列。

自动阈值(计数/尺寸)是一种迭代法。它假定灰度级直方图是两个正常强度分布的总和(两个类):对象像素和背景像素。阈值通常不明显,因为两个分布相互重叠。这里的技巧是找到两个分布相交的地方(这样一来,即使直方图具有清晰的谷,阈值也不一定位于谷值点)。

对于沿直方图 (h(t)) 的每个灰度级 (t),算法计算直方图位于 t (v1(t) 和 v2(t)) 两侧的两个部分之间的方差。它选择使两个归一化方差的总和最小化的灰度级(阈值)。此方差有时被称为“类内”方差,可用以下方程式表示:

vw(t) = s1(t)*v1(t)/S + s2(t)*v2(t)/S

其中:

s1(t) = Sum(h(i),i=1->t),

s2(t) = Sum(h(i),i=t+1->n),

S = Sum(h(i),i = 1->n),

n = 直方图大小。

在实际应用中,算法不是将 vw(t) 最小化,而是将“类间”方差最大化。它更加快速,解释起来也更为复杂,但实际上是一回事。

在计数/尺寸中设置强度范围选择后,转至计数/尺寸|选择测量值 (Count/Size|Select Measurements) 菜单,并选择 PerArea 测量参数。按“确定”(OK) 按钮以接受,然后按“计数”(Count) 按钮计算对象数量。通过选择“视图|统计”(View|Statistics) 菜单打开统计数据表,并观察表中“总和”(Sum) 一行。在 PerArea 列和“总和”(Sum) 行中,有一个小数。将此小数乘以 100,即得到您的图像中的对象的面积百分比。创建任意 AOI(感兴趣区域),然后执行上述相同步骤,将得到 AOI 范围内的对象的面积百分比。

在处理数据表前,应先查看显示内容,以确保您对已经提取的对象满意。您可能需要删除不相关的对象,分离已经被计为单一对象的簇,或将分离的轮廓合并为一个轮廓。在计数/尺寸上:编辑“计数/尺寸编辑菜单”(Count/Size Edit Menu) 菜单,Image-Pro 为您提供多种工具以编辑和最终确定计数。

  • 绘制/合并对象:此选项用于手动绘制未计数的对象的轮廓,或将两个对象合并在一起并计为一个对象。

    要手动包括轮廓,选择“绘制/合并”(Draw/Merge),然后使用任何一个标准 AOI 工具绘制追踪对象的多边形:矩形、椭圆形或任意形状(您甚至还可以使用 Freeform 工具的“自动追踪”(Auto Trace) 功能自动追踪边缘。)多边形绘制完成后,该形状的指定测量值也将被添加到数据表中。

    注意 - 您可以绘制多边形以界定您的图像中不清晰存在的对象。这通常是要界定可以用来计算群密度的区域。

    要将两个位置接近的对象合并为一个对象,只需绘制一个较窄的多边形以连接(不是绘制轮廓)两个现有对象。

    通过这种方式可以合并多个对象,从而绘制区域轮廓以执行群密度分析(见“群密度分析”)。

  • 拆分对象:此选项用于手动将簇拆分为单个对象。拆分方法是在要分割的对象之间绘制一条分割线。

    分割后,测量数据表将更新,以反映出附加的对象,且原始图像的测量值也将进行调整,以反映剩余对象的情况。

  • 自动拆分:您还可以使用自动拆分命令指示 Image-Pro 分析所有现有轮廓并自动拆分其找到的任何簇对象。当然,并非所有的簇对象都可以使用自动拆分功能进行分割。一般情况下,重叠部分最少的圆形对象最适合拆分。按照以下标准确定是否可以通过自动拆分操作轻松分割您的簇对象:

    簇中的单个对象应为凸状。如果所有连接轮廓两点的线条均位于对象内,则认为该对象为凸状。
    对象相互重叠的部分不能超过 30%。
    两个重叠对象的相交处应使用两个凹点进行标识。
    对象轮廓应该足够平滑,以便可以轻松区分由重叠产生的凹面和作为对象一部分的凹面。

    注意 - Image-Pro 使用直线拆分对象。它不重新构建对象缺失或隐藏的部分。

    如果使用自动拆分命令没有得到令人满意的结果,则尝试使用分水岭拆分。该方法无需借助对象凹面确定分割线。而是会削弱对象,直至对象消失,然后再将对象重新扩大到初始大小,但不允许接触其相邻对象。

  • 分水岭拆分:使用分水岭拆分自动分析每一个计数的对象,并使用分水岭分割方法拆分簇。分水岭方法削弱对象,直至对象消失,然后再将对象扩大,但确保其不相互接触。

    如果对象不是凸状,分水岭拆分命令可能比自动分割方法更有效。

    您可以使用计数/尺寸中的“打开/关闭对象”(Toggle Objects On/Off) 功能清除计数中不相关的对象:编辑菜单。隐藏对象后,其轮廓和标记从显示中删除,测量值从数据表中删除。停用的测量值也从全局统计数据、分类和可视化操作中被排除。要永久性删除隐藏的对象,则从相同的“计数/尺寸:编辑”(Count/Size:Edit) 菜单中选择“删除隐藏的对象”(Delete Hidden Objects)。

Measurement calibration is possible using reticules available from many Image-Pro dealers and microscope suppliers and well as companies such as Edmund Scientific and Fisher Scientific. Kodak has a variety of targets available for calibration of non-microscopic optical systems. For larger objects you should not neglect the possibility of imaging a set of accurate rulers, if they are flat enough to lie in the same optical plane as the objects.

There are many kinds of calibration standards available, including targets for calibrating angle, distance, intensity, linearity, and the spatial frequency response (Modulation Transfer Function or the Optical Transfer Function - MTF and OTF). The choice of which standard to use depends on what measurements you are making.

You should calibrate your measurements of importance both at the center of your imaging field and at the edges to ensure that your optical system is reasonably flat and undistorted. Total system precision is limited by the maximum of the smallest resolution of the system (how large is a pixel, how many gray scales can be distinguished), the limit of optical resolution, and optical distortions. System accuracy is limited by the sum of these resolution limitations and the base accuracy of your calibration standard as listed by the manufacturer. (Accuracy = adherence to an absolute standard, Precision = repeatability.)

A note about calibrating X and Y axis: No matter what optical system you use, as long as the image is digitized by a camera, a frame grabber, or a scanning device, you have to assume that the digitization process does not have a one-to-one aspect ratio. If that is the case, you will have to calibrate both X and Y axis. Image-Pro allows you to calibrate both axis, or to calibrate one axis and set the aspect ratio. Once calibrated, the program will give you correct spatial measurements regardless of the direction of measurement. Calibration and calibrated measurements are also covered extensively in Media Cybernetics software manuals.

对于空间校准而言,纵横比反映图像中的垂直轴和水平轴的长度关系,用 X/Y 表示。纵横比也可通过校准命令进行校准。如果相机的纵横比和视频卡的纵横比不相等,则方形对象的图像在显示器上不会显示为方形。要纠正这种不一致,您可以使用图像中的参考方形校准纵横比。

注意 - 相机/视频卡不一致不是方形在显示器上不显示为方形的唯一原因。它可能只是因为未正确调整监视器的垂直尺寸控制。

Media Cybernetics 和 Velquest 建立了合作伙伴关系。
VelQuestis 是领先的合规管理系统供应商,其系统基本上消除了繁冗的人工文书工作,为数据交换提供了一个通用平台。VelQuestis 围绕联邦法规第 21 章第 11 款的合规问题提供丰富的产品和服务,尤其是在制药领域。通过战略合作,Image-Pro Plus 和 VelQuestSmartShell 技术补救解决方案一起运行。

Image-Pro has the ability to add a personal electronic signature to image and report files.

The Audit Trail is similar to the macro recorder, but trageted at keeping a log of everything that is done in Image Pro on a daliy basis. When enabled (Choose Edit|Preferences... and check Generate audit trail log.), the Audit trail feature creates a log of the equivalent macro call for every action you perform in Image Pro Plus. In addition, each line is prefeaced with the full time and date that the action was performed.

Below is a sample of the audit trail log:


2001/10/22 16:19:22.310 Image-Pro Plus logging started.
2001/10/22 16:19:23.570 ret = IpAcqShow(ACQ_SNAP, 0)
2001/10/22 16:19:30.710 ret = IpDocMove(0, 0)
2001/10/22 16:19:30.710 ret = IpAppSelectDoc(0)
2001/10/22 16:19:30.820 ret = IpDocSize(349, 288)
2001/10/22 16:19:30.820 ret = IpWsLoad("C:\IPWin45\Images\DemoGrn.TIF","tif")
2001/10/22 16:19:40.210 ret = IpDocMove(22, 22)
2001/10/22 16:19:40.210 ret = IpAppSelectDoc(1)
2001/10/22 16:19:40.210 ret = IpDocMove(6, 24)
2001/10/22 16:19:40.210 ret = IpDocSize(349, 288)
2001/10/22 16:19:40.210 ret = IpWsLoad("C:\IPWin45\Images\DemoBlue.TIF","tif")
2001/10/22 16:19:40.270 ret = IpDocMove(44, 44)
2001/10/22 16:19:40.270 ret = IpAppSelectDoc(2)
2001/10/22 16:19:40.270 ret = IpDocMove(12, 48)
2001/10/22 16:19:40.270 ret = IpDocSize(349, 288)
2001/10/22 16:19:40.270 ret = IpWsLoad("C:\IPWin45\Images\DemoRed.TIF","tif")
2001/10/22 16:19:56.970 ret = IpCmChannelMerge3(0, 2, 0, 1, CM_RGB, 1)
2001/10/22 16:19:57.020 ret = IpDocMove(66, 66)
2001/10/22 16:19:57.020 ret = IpAppSelectDoc(3)
2001/10/22 16:19:57.020 ret = IpDocMove(18, 72)
2001/10/22 16:19:57.020 ret = IpDocSize(349, 288)
2001/10/22 16:20:04.600 ret = IpCmpShow( COMP_SHOW )
2001/10/22 16:20:07.240 ret = IpCmpShow( COMP_HIDE )
2001/10/22 16:20:18.550 ret = IpCoLocShow(1)
2001/10/22 16:20:26.190 Image-Pro Plus logging ended.

This log file give you a per session record of what was done to an image, and can be used as a guide for reproducing your actions. You may also notice that by simply removing the date and time at the beginning of each line, and wrapping the resulting text with Sub Subname() and End Sub statements you can very quickly generate a macro to repeat exactly what you just did.

自从发布版本 4.5.1 后,许多用户在将扩展名为 .raw 的文件导入到 Image-Pro Plus 时遇到了困难。这是因为 .raw 不是标准格式。每一个创建 .raw 文件的软件产品和制造商都采用不同的 .raw 格式定义。我们的 .raw 文件则以国家卫生研究院 (NIH) .raw 格式为基础。如果这给您带来了不便,您可以禁用内置的 .raw 格式,并继续使用您一直使用的平面文件描述符。

您可以通过将一个区段添加到 IPWIN32.INI 文件的方式完成此操作。使用 Notepad(开始|程序|附件|Notepad)编辑此文件,并添加和如下类似的区段:

[ReservedExts]
RAW=1

在上述示例中,消除了不兼容的 NIH (RAW) 格式。如果您要删除更多格式,只需在 ReservedExts 区段添加更多行。在每一行中要使用该格式的文件扩展名(例如,适用于 BioRad 的 PIC)。

注意:必须安装 Image-Pro Plus v4.5.1.25 或更高版本才能使用此功能。

Image-Pro 的其中一个最为强大的功能是允许您对图像手动或自动执行空间测量。在 Image-Pro 中执行测量有两种基本方式:

  • 手动测量单一对象。使用“测量”(Measure) 菜单中的“测量值”(Measurements) 命令可以测量您界定的线条或多义线长度、多边形面积及弧形角度。“测量值”(Measurements) 命令还可用于自动追踪和测量图像中的对象或特征的边缘。您可以测量任意两个特征之间的距离,并使用 Image-Pro Plus 版本 4.0 中的新功能执行容差测试。
  • 自动计数和测量多个对象。使用“测量”(Measure) 菜单上的工具可收集单一图像中的多个对象的多个测量值。如果您的目标是计算样本中的细胞数量,并测量这些细胞的面积、圆度或周长,可以使用该工具。计数和测量对象后,可以使用“计数/尺寸”(Count/Size) 窗口的“测量”(Measure) 菜单选项自动按任何测量的特征对对象排序和分类。还可通过在散点图上绘制分类数据或按类对计数的对象伪染色的方式对分类数据可视化。
  • 手动计数和测量多个对象。使用“测量”(Measure) 菜单上的“手动标记”(Manual Tag) 选择可收集单一图像中的多个对象的多个测量值。也可以选择一个类中的对象数量(最多 256 个)和单个图像中的类的数量(最多 16 个),以及用于识别每个类的颜色、符号和名称。

注意 - 如果您的系统配置了数学协处理器,则计数和测量操作将利用该数学协处理器。如果您没有数学协处理器,但计划要执行大量计数和定径工作,可能要考虑安装一个数学协处理器。

完成测量后,Image-Pro 高亮显示测量轮廓,并指定一个参考编号。默认情况下,Image-Pro 以黄色显示其测量轮廓,以蓝色显示参考编号,但如果您要使用其他颜色,可以使用计数/尺寸或测量窗口中的操作按钮指定颜色。在您关闭图像或使用“删除测量值”(Delete Measurements) 按钮明确删除测量值前,测量值将一直显示在屏幕上。

使用“计数/尺寸”(Count/Size) 命令自动执行测量后,测量值记录在数据表上。您只需双击图像中的测量对象,便可查看测量信息。

您可以通过选择“计数/尺寸”(Count/Size) 窗口上的“查看”(View) 菜单上的“测量数据”(Measurement Data) 命令查看所有当前测量值。此时将打开“测量数据”(Measurement Data) 窗口,并在其中显示活跃的 AOI 或图像的数据表。使用“测量数据”(Measurement Data) 窗口的“文件”(File) 菜单上的“将数据保存到文件”(Data to File) 命令可以保存测量数据。测量值以 ASCII 形式 (*.CNT) 存储。测量文件的格式在附录 B“Image-Pro 文件格式规范参考指南”中进行了定义。

测量操作根据图像像素位置进行,例如,测量长度由沿线条的像素数确定,轮廓对象的面积由该轮廓内的像素数确定,诸如此类。

注意 - 当 Image-Pro 执行测量时,轮廓中包括的像素数包括在测量中。例如,当您测量您绘制出轮廓的对象的面积时,构成该轮廓的像素数包括在面积的计算中。

Image-Pro 的像素级测量可以扩展到适合任何坐标系。因此您可以获得对您的应用有意义的测量报告。例如,您可以校准测量比例,使一个像素数等于一英尺,或者使五个像素数等于一英尺(或英寸、英里、微米)。可以使用分数值。Image-Pro 将以该单位表示测量值。而且,如果您的图像包含单位长度的可测量对象,您可以使用“空间校准”(Spatial Calibration) 对话框中的“图像”(Image) 按钮,直接以该对象校准比例。

重要 - 在进行测量前,先校准比例。一旦测量值被记录,其值就不受空间校准中的任何后续更改的影响。例如,如果用线条测量 50 个像素数,其中 1 个单位等于 1 个像素数,然后再将校准更改为 1 个单位等于 10 个像素数,则第一次记录的测量值仍为 50。在更改校准后,Image-Pro 不会自动将其重新缩放到 5。必须再次测量,才能反映新的校准。

识别要执行的测量后,可以设定测量标准以确定 Image-Pro 在计数中要包括的对象。

例如,您可以指示 Image-Pro 仅包括大于特定大小的对象。为了完成此操作,可以使用“测量”(Measure) 菜单中的“设定范围”(Set Ranges) 命令设定每次测量的有效范围(即指定最小值和最大值)。如果对象的测量值处于此范围内(在最小值和最大值(含)之间),则包括在计数中。值超出该范围的对象则被忽略。

使用“测量”(Measure) 菜单上的“计数/尺寸”(Count/Size) 命令可自动计数和测量多个对象。计数和测量对象后,可以使用“计数/尺寸”(Count/Size) 窗口的“测量”(Measure) 菜单自动按任何测量的特征对其分类。
还可以通过使用“计数/尺寸”(Count/Size) 窗口的“查看”(View) 菜单选项绘制数据图的方式将数据可视化或通过使用“计数/尺寸:测量”(Count/Size:Measure) 菜单上的“自动分类”(Auto Classification) 命令按类对计数的对象染色。

Image-Pro Plus 版本 4.0 中的一项新功能可用来根据面积或其他测量值对计数的对象排序。使用“测量”(Measure) 菜单上的“对对象排序”(Sort Objects) 选项可按排序顺序生成对象的新图像。

空间校准对话框可用于在图像上放置校准标记物,它可轻松记载图像中的对象的缩放比例,因此在出版中有用。但是,许多人发现校准标记物在嵌入到图像中后仅部分可见(或完全不可见)。

这是因为校准标记物是作为一组 1 像素宽的线条嵌入的。使用 1 像素宽的线条是因为要避免在使用这些线条再次校准图像时引起“边缘在哪里”的问题。线条没有消失,只是隐藏了起来。随着百万像素数码相机的日益普及,许多人的图像会自动缩小到全尺寸的 50% 甚至是 25%,使图像全屏显示。Image-Pro 减小了图像在屏幕上的显示尺寸,使其隔一行和隔一列显示像素数(缩放 50%)。如果嵌入的校准标记物线条恰好在隐藏的其中一列或一行中,则该线条将隐藏。如果将图像缩放到 100% 或更大比例,这些隐藏的线条就会显示。


实用资源

视频教程

显示更多内容 >

社区文章

显示更多内容 >

实用资源

相机支持

显示更多内容 >

显微镜硬件支持

显示更多内容 >
登录以获得软件提示、网络研讨会、出版物等相关信息